[백준] 2178번 C/C++ 풀이 _ 미로 탐색



출처 : https://www.acmicpc.net/problem/2178 

시간 제한메모리 제한제출정답맞은 사람정답 비율
2 초128 MB306579557587729.942%

문제

N×M크기의 배열로 표현되는 미로가 있다.

101111
101010
101011
111011

미로에서 1은 이동할 수 있는 칸을 나타내고, 0은 이동할 수 없는 칸을 나타낸다. 이러한 미로가 주어졌을 때, (1, 1)에서 출발하여 (N, M)의 위치로 이동할 때 지나야 하는 최소의 칸 수를 구하는 프로그램을 작성하시오.

위의 예에서는 15칸을 지나야 (N, M)의 위치로 이동할 수 있다. 칸을 셀 때에는 시작 위치와 도착 위치도 포함한다.

입력

첫째 줄에 두 정수 N, M(2≤N, M≤100)이 주어진다. 다음 N개의 줄에는 M개의 정수로 미로가 주어진다. 각각의 수들은 붙어서 입력으로 주어진다.

출력

첫째 줄에 지나야 하는 최소의 칸 수를 출력한다. 항상 도착위치로 이동할 수 있는 경우만 입력으로 주어진다.

예제 입력 

4 6
101111
101010
101011
111011

예제 출력 

15

예제 입력 2 

4 6
110110
110110
111111
111101

예제 출력 2 

9

힌트

출처

  • 데이터를 추가한 사람: poia0304

>> 문제풀이

문제를 보면 최단거리만 찾으면 되기 때문에 dfs 보다는 bfs 를 이용하여 답이 하나라도 나오면 종료하는 것이 낫다고 판단했다.
나는 queue를 두 개 사용하여 while 문을 이용하여 구사했는데, 다른 예제를 보면 while 문 안에서 size() 함수를 사용하는 것이 아니라 미리 queue 에 있는 요소들의 갯수를 세서 for 문을 구현했다. 

>> 소스코드

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
#include <iostream>
#include <queue>
 
using namespace std;
 
int** visited;
int** maze;
int N, M;
int answer = 0
int round_row[4= {  010-1 };
int round_col[4= { -1010  };
queue<pair<intint>> next_position;
queue<pair<intint>> next_sub_position;
 
// 주변 4개 점 확인 
void checkRound(pair<intint> now_position) {
 
    for (int i = 0; i < 4; i++) {
        int now_row = now_position.first + round_row[i];
        int now_col = now_position.second + round_col[i];
 
        // 조건 체크. maze 안에 있으면서, maze 의 요소가 0이 아니고 
        // 방문한 노드가 아닐 경우에 다음 노드로 추가 
        if ((0 <= now_row) && (now_row < N) && (0 <= now_col) && (now_col < M) && 
            (!visited[now_row][now_col]) && (maze[now_row][now_col])) {
            visited[now_row][now_col] = 1;
            next_sub_position.push({ now_row, now_col });
        }
    }
}
 
void bfs() {
    // 시작점
    visited[0][0= 1;
    answer++;
 
    // 주변 점 체크 
    checkRound({ 0,0 });
 
    // 다음 라운드로 진행하기 위하여 queue 값을 이동 
    while (next_sub_position.size()) {
        next_position.push(next_sub_position.front());
        next_sub_position.pop();
    }
 
    while (true) {
        answer++;
 
        while (next_position.size()) {
            pair<int ,int> now_position = next_position.front();
            next_position.pop();
 
            // 끝점이면 종료 
            if ((now_position.first == (N - 1)) && (now_position.second == (M - 1))) return
            checkRound(now_position);
        }
 
        // 다음 라운드로 진행하기 위하여 queue 값을 이동 
        while (next_sub_position.size()) {
            next_position.push(next_sub_position.front());
            next_sub_position.pop();
        }
    }
}
 
int main() {
    cin >> N >> M; 
 
    // 배열 선언 
    maze = (int**)malloc(sizeof(int*)*N);
    visited = (int**)malloc(sizeof(int*)*N);
 
    for (int i = 0; i < N; i++){
        maze[i] = (int*)malloc(sizeof(int)*M);
        visited[i] = (int*)malloc(sizeof(int)*M);
    }
 
    // 미로 값 넣기
    for (int i = 0; i < N; i++) {
        for (int j = 0; j < M; j++) {
            scanf("%1d"&maze[i][j]);
            visited[i][j] = 0;
        }
    }
 
    bfs();
    cout << answer; 
 
    return 0
}
cs