출처 : https://www.acmicpc.net/problem/1987
알파벳 성공
시간 제한 | 메모리 제한 | 제출 | 정답 | 맞은 사람 | 정답 비율 |
---|---|---|---|---|---|
2 초 | 128 MB | 15070 | 5163 | 3132 | 32.179% |
문제
세로 R칸, 가로 C칸으로 된 표 모양의 보드가 있다. 보드의 각 칸에는 대문자 알파벳이 하나씩 적혀 있고, 좌측 상단 칸 (1행 1열) 에는 말이 놓여 있다.
말은 상하좌우로 인접한 네 칸 중의 한 칸으로 이동할 수 있는데, 새로 이동한 칸에 적혀 있는 알파벳은 지금까지 지나온 모든 칸에 적혀 있는 알파벳과는 달라야 한다. 즉, 같은 알파벳이 적힌 칸을 두 번 지날 수 없다.
좌측 상단에서 시작해서, 말이 최대한 몇 칸을 지날 수 있는지를 구하는 프로그램을 작성하시오. 말이 지나는 칸은 좌측 상단의 칸도 포함된다.
입력
첫째 줄에 R과 C가 빈칸을 사이에 두고 주어진다. (1<=R,C<=20) 둘째 줄부터 R개의 줄에 걸쳐서 보드에 적혀 있는 C개의 대문자 알파벳들이 빈칸 없이 주어진다.
출력
첫째 줄에 말이 지날 수 있는 최대의 칸 수를 출력한다.
예제 입력 1
2 4 CAAB ADCB
예제 출력 1
3
출처
Olympiad > Croatian Highschool Competitions in Informatics > 2002 > Regional Competition - Juniors 3번
풀이
stack 을 이용하여 다음 방문할 노드들을 계속 stack 에 추가해준다.
stack이 빌 때까지, 다음 방문할 노드들을 검사하여 row, col, 방문한 노드의 비트마스크, 방문한 노드의 개수를 구조체에 넣어준다.
자세한 설명은 소스코드를 참조하면 된다.
소스코드
#include <iostream>
#include <stack>
#pragma warning(disable : 4996)
using namespace std;
#define MAX 20 + 1
#define WAY_NUM 4
typedef struct NODE {
int _row;
int _col;
int _is_visited;
int _visited_num;
};
// 상하좌우
int way[WAY_NUM][2] = { { 0,-1 },{ 0,1 },{ -1,0 },{ 1,0 } };
int main() {
// init
int R, C;
int answer =1;
char arr[MAX][MAX];
stack<NODE> search_stack;
scanf("%d %d", &R, &C);
for (int r_idx = 0; r_idx < R; r_idx++)
scanf("%s", &arr[r_idx]);
search_stack.push({0,0, (1 << (arr[0][0]-'A')), 1 });
// dfs 시작
while (!search_stack.empty()) {
NODE _this_posi = search_stack.top();
search_stack.pop();
// 상하좌우 탐색
for (int way_idx = 0; way_idx < WAY_NUM; way_idx++) {
int _find_row = _this_posi._row + way[way_idx][0];
int _find_col = _this_posi._col + way[way_idx][1];
int _visited_num = _this_posi._visited_num + 1;
int _is_next_visited = (_this_posi._is_visited) & (1 << (arr[_find_row][_find_col] - 'A' ) );
if ( (_find_row < 0) || (_find_row >= R) ) continue;
if ( (_find_col < 0) || (_find_col >= C) ) continue;
if (_is_next_visited) continue;
if (answer < _visited_num) answer = _visited_num;
search_stack.push({ _find_row , _find_col ,
(_this_posi._is_visited) | (1 << (arr[_find_row][_find_col] - 'A')) , _visited_num});
}
}
cout << answer;
return 0;
}