[백준] 1137번 C/C++ 풀이 _ 가장 많은 글자



출처 : https://www.acmicpc.net/problem/1371 

시간 제한메모리 제한제출정답맞은 사람정답 비율
2 초128 MB277698183937.389%

문제

영어에서는 어떤 글자가 다른 글자보다 많이 쓰인다. 에를 들어, 긴 글에서 약 12.31% 글자는 e이다.

어떤 글이 주어졌을 때, 가장 많이 나온 글자를 출력하는 프로그램을 작성하시오.

입력

첫째 줄부터 글의 문장이 주어진다. 글은 최대 5000글자로 구성되어 있고, 공백, 알파벳 소문자, 엔터로만 이루어져 있다. 그리고 적어도 하나의 알파벳이 있다.

출력

첫째 줄에 가장 많이 나온 문자를 출력한다. 여러 개일 경우에는 알파벳 순으로 앞서는 것부터 모두 공백없이 출력한다.

예제 입력 1 

english is a west germanic
language originating in england
and is the first language for
most people in the united
kingdom the united states
canada australia new zealand
ireland and the anglophone
caribbean it is used
extensively as a second
language and as an official
language throughout the world
especially in common wealth
countries and in many
international organizations

예제 출력 1 

a

출처

알고리즘 분류

풀이

간단하게 세주면 되는 문제입니다. 
다만, 입출력이 뭔가 잘 안된다는 느낌을 많이 받았습니다. 

소스코드 2개가 있으니 각각 참고해주세요~~
이 소스코드가 visual studio 에서는 작동하지 않을 수도 있습니다. 

소스코드 1

1
2
3
4
5
6
7
8
9
10
11
12
13
#pragma warning(disable:4996)
#include <cstdio>
int big, num[33];
char c;
int main() {
    while (~scanf("%c"&c)) 
        num[c - 'a']++;
    for (c = 0; c < 26; c++
        if (big > num[c]) big =  num[c];
    for (c = 0; c < 26; c++
        if (num[c] == big) printf("%c", c + 'a');
    return 0;
}
cs

소스코드 2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <stdio.h>
using namespace std;
int main() {
    int C, t;
    int ans[26= { 0 }, max = 0;
    string s;
    vector<int> input;
    while (cin >> s) {
        for (int i = 0; i < s.length(); i++
            ans[s[i] - 'a']++
        s = "";
    }
    for (int i = 0; i < 26; i++)
        if (max < ans[i])max = ans[i];
    for (int i = 0; i < 26; i++
        if (ans[i] == max)cout << (char)('a' + i); 
    return 0
cs